System Requirements

 

     ■Computer

A basic IBM PC compatible computer will work great with the software mentioned below, however, you need at least 64 MB RAM, and a Pentium class processor to install the software and run the programs.

 

     ■Software

You will need Adobe Acrobat Reader 5.1 to view the application and online courses.  If you do not have Acrobat or if you have an older version of Adobe Acrobat Reader (you will need the most current version of Adobe Acrobat Reader), then you can download it for free from the following web-site address:            http://www.adobe.com/products/acrobat/readstep2.html

 

Completing online courses is easier with Adobe Acrobat. This will enable you to return your completed course work via e-mail. The seminary may be able to obtain a copy of Adobe Acrobat 6 for you at a discounted price. Contact Dr. Philip Bryan for more details.

 

Acrobat eBook Reader 2.2 is needed for the occasional eBook you may come across.  You can download it for free from http://www.adobe.com/products/ebookreader/main.html

 

This site is best viewed with Internet Explorer 6.  You can download this for free at http://www.microsoft.com/windows/ie/downloads/ie6/download.asp